首页
登录 | 注册

基础学习:RIP-V2协议概述(二)

4 无类路由协议

  无类别路由选择协议最根本的特点,是它可以在路由通告中携带子网掩码。每条路由拥有子网掩码的一个好处就是,全0和全1的子网现在可以利用了。

  在缺少条件下,即使正在运行无类别路由选择协议,CISCO IOS软件也将拒绝尝试把一个全0的子网配置为有效的地址/掩码组合。为了忽略这个缺省的行为,可以使用全局命令IP subnet-zero.

  每条路由拥有子网掩码的另一个很大的好处,就是可以使用可变长子网掩码和利用一条单一的聚合地址来汇总一组主网络地址。

  5 可变长子网掩码

  如果每一个目的地址都可以单独地携带相关联的子网掩码通告到整个网络中,那么就没有什么理由要求所有的掩码必须是等长的了。这个事实就是使用可变长子网掩码(VLSM)的好处之一。

  VLSM技术的关键之处就是:当一个网络地址依据标准的方式被划分子网以后,那些子网本身也能够进一步被子网化。

  点到点的链路需要子网地址,但每个子网只需要两个主机地址,这就是使用VLSM的一个理由。

 三 RIP-V2的配置

  由于RIP-V2只是RIP-V1的增强版,而不是一个单独的协议,因此,在RIPV1中介绍的某些命令可以同样的方法在RIP-V2中正确使用。

  1 基本配置

router rip
version 2
network 172.25.0.0
network 192.168.50.0

  可以在路由器配置模式(config-router mode)下键入命令NO VERSION恢复到原来的缺省方式。

  2 RIP-V2与V1相结合

  基于端口级别(interface-level)的"兼容性开关"。用"ip rip send version 版本号"和"Ip rip recevie version 版本号"来实现。

router(config)#interface ethernet0
router(config-if)#no shutdown
router(config-if)#ip address 192.168.50.1 255.255.255.0
router(config-if)#ip rip send vervion 1
router(config-if)#ip rip receive verion 1 (RIP V1 mode)
router(config-if)#interface ethernet 1
router(config-if)#no shutdown
router(config-if)#ip address 172.25.150.1 255.255.0.0
router(config-if)#ip rip send version 1 2 (RIP V1 V2 mode)
router(config-if)#interface ethernet 2
router(config-if)#no shutdown
router(config-if)#ip address 172.50.0.0 255.255.0.0
router(config-if)#end
router(config)#router rip
router(config-router)#version 2
router(config-router)#network 172.25.0.0
router(config-router)#network 192.168.0.0

  3 使用可变长子网掩码

  划分子网的基本目的总是相同的:路由器必须能够使用惟一的地址来标识每一条数据链路,以区别于互联网中的其他地址。

  4 不连续的子网和无类路由

  无类路由选择协议并没有关于不连续子网的这些困难。因为每一条路由更新都包含一个子网掩码,因而一个主网络的子网能够通告给另一个主网络

  RIP-V2协议缺省的行为要在主网络边界上进行路由汇总,为了关闭路由汇总功能以允许被通告的子网通过主网络的边界,可以在RIP的处理中使用 no auto-summary

router(config)#router rip
router(config-router)#version 2
router(config-router)#network 172.25.0.0
router(config-router)#network 192.168.0.0
router(config-router)#no auto-summary


相关文章

  • 目前人工智能和大数据火热,使用的场景也越来越广,日常开发中前端同学也逐渐接触了更多与大数据相关的开发需求.因此对大数据知识也有必要进行一些学习理解 大数据的本质 基础知识 学习路线 数据采集引擎 -> Sqoop.Flume ZooK ...
  • .NET基础学习:经典水晶报表设计三则一.经典水晶报表设计三则之"分栏" 借助"多列格式化"功能实现. 1. 启用"多列格式化"功能. (1) 进入"节专家"对 ...
  • 根据TIOBE编程语言排行榜2019年三月份榜单排名,Java语言位居榜首.Java语言以其良好的面向对象设计思想获得了市场和程序员的喜爱.那么你是否想要学习Java语言了,毕竟TIOBE的排名代表着程序语言的未来趋势.针对零基础的初学者, ...
  • 【Java Web开发】数据库及SQL/MySQL基础
    详细课程链接:[Java Web开发]数据库及SQL/MySQL基础 -- 阿里云大学 MySQL概述 什么是数据库 ? 答:数据的仓库,如:在ATM的示例中我们创建了一个 db 目录,称其为数据库 什么是 MySQL.Oracle.SQL ...
  • SNMP从入门到开发:基础篇
    SNMP协议入门 1.引言 基于TCP/IP的网络管理包含3个组成部分: 1) 一个管理信息库MIB(Management Information Base).管理信息库包含所有代理进程的所有可被查询和修改的参数.RFC 1213[McCl ...
  • 在网上下载net-snmp5.7.3版本的源码,将其解压到Linux系统之中. gcc编译net-snmp 进入解压的net-snmp源码根目录下,输入以下命令: ./configure --prefix=/usr/local/net-sn ...

2020 unjeep.com webmaster#unjeep.com
12 q. 0.013 s.
苏ICP备12049786号-20